System Health

Our system health is a real-time view of the performance of Sprout. Bookmark this page and check back if you experience any interruptions.

Subscribe to Updates
Glassdoor Reply and Connection Issue
Incident Report for Sprout Social
Resolved
The issue with Glassdoor appears to be resolved. Please subscribe to receive status updates.
Posted Jan 04, 2021 - 15:57 CST
Investigating
Glassdoor is currently experiencing difficulties that affects replying and connecting profiles. We are monitoring the situation and apologize for any inconvenience. Please subscribe to receive status updates.
Posted Dec 30, 2020 - 10:40 CST
This incident affected: Sprout Social Web Application.